Keep getting error 422

Had this once before but on a day when there were known issues. But Nomics status page says all no issues reported. Anyone else getting this today. Using Power Query (Excel 2019).

Hi Stu,

Error 422 means you’re exceeding the rate limits of your plan. Free plans are limited to one request per second.

Thanks, though I haven’t tried querying anywhere near that frequent usually 15 time a day. My colleague has same error. I even tried new unused key to test that.

Can you reach out to support@nomics.com and include your API key? Then we can look it up for you.

Back again. I’ve emailed them. I’m not particularly savvy with query requests, but I deleted existing query and tried setting it up again, but still get 422 at authenticate as anonymous step. Meanwhile I’ll just wait for support to reply.

I think this is caused by the prices endpoint depreciation and this is annoying and I don’t seem to see a replacement and without the ability to get the price, it’s pretty useless

https://nomics.com/docs/#operation/getPrices

I was also getting this error. So i ran my query directly in the browser’s address bar and got a much more helpful message:

Your plan requires that you provide a per-page argument. See http://docs.nomics.com/ for more information.

So I added the &per-page=100 argument at the end of the query and it works again.

I could not find anything in the API docs that mentions this new change, but maybe the docs get updated soon…

Hope this helps ya too